
 

 

ot
e

te
ch

ni
ca

l n
ot

e
te

ch
n

Document is available to the public
through the National Technical Information
Service, Springfield, Virginia  22161

U.S. Department of Transportation
Federal Aviation Administration

William J. Hughes Technical Center
Atlantic City International Airport, NJ  08405

ot
e

te
ch

ni
ca

l n
ot

e
te

ch
n

Document is available to the public
through the National Technical Information
Service, Springfield, Virginia  22161

U.S. Department of Transportation
Federal Aviation Administration

William J. Hughes Technical Center
Atlantic City International Airport, NJ  08405

ot
e

te
ch

ni
ca

l n
ot

e
te

ch
n

Document is available to the public
through the National Technical Information
Service, Springfield, Virginia  22161

U.S. Department of Transportation
Federal Aviation Administration

William J. Hughes Technical Center
Atlantic City International Airport, NJ  08405

ot
e

te
ch

ni
ca

l n
ot

e
te

ch
n

Document is available to the public
through the National Technical Information
Service, Springfield, Virginia  22161

U.S. Department of Transportation
Federal Aviation Administration

William J. Hughes Technical Center
Atlantic City International Airport, NJ  08405

ot
e

te
ch

ni
ca

l n
ot

e
te

ch
n

Document is available to the public
through the National Technical Information
Service, Springfield, Virginia  22161

U.S. Department of Transportation
Federal Aviation Administration

William J. Hughes Technical Center
Atlantic City International Airport, NJ  08405

ot
e

te
ch

ni
ca

l n
ot

e
te

ch
n

Document is available to the public
through the National Technical Information
Service, Springfield, Virginia  22161

U.S. Department of Transportation
Federal Aviation Administration

William J. Hughes Technical Center
Atlantic City International Airport, NJ  08405

ot
e

te
ch

ni
ca

l n
ot

e
te

ch
n

Document is available to the public
through the National Technical Information
Service, Springfield, Virginia  22161

U.S. Department of Transportation
Federal Aviation Administration

William J. Hughes Technical Center
Atlantic City International Airport, NJ  08405

ot
e

te
ch

ni
ca

l n
ot

e
te

ch
n

Document is available to the public
through the National Technical Information
Service, Springfield, Virginia  22161

U.S. Department of Transportation
Federal Aviation Administration

William J. Hughes Technical Center
Atlantic City International Airport, NJ  08405

Core Commands Across  
Airway Facilities Systems 
 

 
 
Vicki Ahlstrom, ACB-220 
Robert Muldoon, Northrop Grumman Information Technology 

 

 

 

 

 

 

May 2003 
DOT/FAA/CT-TN03/15 
 



 

 

 

 

 

 

 

 

 

 

NOTICE 
 

This document is disseminated under the sponsorship of the U.S. 
Department of Transportation in the interest of information 
exchange.  The United States Government assumes no liability for 
the contents or use thereof.  The United States Government does 
not endorse products or manufacturers.  Trade or manufacturers’ 
names appear herein solely because they are considered essential 
to the objective of this report.  This document does not constitute 
FAA certification policy.  

 

 



 

 

 

  Technical Report Documentation Page 
1.  Report No. 
DOT/FAA/CT-TN03/15 
 

2.  Government Accession No. 3.  Recipient’s Catalog No. 

5.  Report Date 
May 2003 

4.  Title and Subtitle 
Core Commands Across Airway Facilities Systems 
 

6.  Performing Organization Code 
ACB-220 
 

7.  Author(s)  
Vicki Ahlstrom, ACB-220 and Robert Muldoon, Northrop Grumman 
Information Technology 
 

8.  Performing Organization Report No. 
DOT/FAA/CT-TN03/15 

10.  Work Unit No. (TRAIS) 
 
 

9.  Performing Organization Name and Address 
Federal Aviation Administration 
William J. Hughes Technical Center 
Atlantic City International Airport, NJ  08405 
 

11.  Contract or Grant No. 
 

13.  Type of Report and Period Covered 
Technical Note 

12.  Sponsoring Agency Name and Address 
Federal Aviation Administration  
Human Factors Division 
800 Independence Ave., S.W. 
Washington, DC  20591 
 

14.  Sponsoring Agency Code 
AAR-100 

15.  Supplementary Notes 
 
 
16.  Abstract  
This study takes a high-level approach to evaluate computer systems without regard to the specific method of 
interaction.  This document analyzes the commands that Airway Facilities (AF) use across different systems and 
the meanings attributed to the different commands.  Human factors researchers collected data on AF systems and 
equipment, identifying 25 different systems monitored and controlled by AF specialists.  Different AF systems 
had different means of interfacing with the computer (e.g., graphical user interface, menus, and command line 
interface).  The researchers summarized data on the interaction types across AF systems to find that most AF 
systems used menus as the primary means of interaction.  Among the 25 systems monitored and controlled by 
AF, they uncovered more than 1500 options for accessing, interacting with, and controlling the equipment 
necessary to National Airspace System operations.  They analyzed the options for frequency of occurrence and 
defined meanings for each of the most frequently used options.  The result of this analysis is a set of core 
commands that are common across a number of systems. 
 

17.  Key Words 
 
Airway Facilities 
Commands 

18.  Distribution Statement This document is 
available to the public through the National 
Technical Information Service, Springfield, 
Virginia, 22161 

19.  Security Classif. (of this report) 
Unclassified 

20.  Security Classif. (of this page) 
Unclassified 

21. No. of Pages 
24 

22.  Price 

Form DOT F 1700.7 (8-72)  Reproduction of completed page authorized   



 

iii 

Table of Contents 

Page 

Executive Summary .........................................................................................................................v 
1. Introduction..................................................................................................................................1 

1.1 System Interaction Methods ..................................................................................................1 
1.2 Purpose...................................................................................................................................2 

2. Method .........................................................................................................................................2 
2.1 Site Visits ...............................................................................................................................2 
2.2 Data Collection ......................................................................................................................3 
2.3 Procedure ...............................................................................................................................3 

3. Results..........................................................................................................................................4 
3.1 Systems and Displays in the AF Environments.....................................................................4 

3.1.1 Frequency of Option Occurrence....................................................................................7 
4. Conclusions..................................................................................................................................8 
References......................................................................................................................................17 
Acronyms.......................................................................................................................................18 

 

 

List of Illustrations 

Table Page 

Table 1.  Potential Core Functions...................................................................................................3 
Table 2.  Individual System Information .........................................................................................4 
Table 3.  Method of Option Access Across Systems.......................................................................7 
Table 4.  Most Frequently Encountered Options Across Systems...................................................8 
Table 5.  Common AF Commands ..................................................................................................9 
Table 6.  Table of Additional Commands......................................................................................15 
 



 

iv 



 

v 

Executive Summary 

In previous studies, researchers from the William J. Hughes Technical Center Human Factors 
Group (ACB-220) have catalogued Airway Facilities (AF) interactions with icons, function and 
shortcut keys, and mnemonics and menus (Ahlstrom & Muldoon, 2002; Ahlstrom & Muldoon, 
2003a, 2003b).  Each of these reports focused on a single aspect of interaction with AF computer 
systems.  In this study, they take a higher-level approach and evaluate computer systems without 
regard to the specific method of interaction.  This document analyzes the commands that AF 
specialists use across different systems and the meanings attributed to the different commands.  
This analysis results in a set of core commands that are common across a number of systems.  

Human factors researchers compiled a list of potential core commands by analyzing computer-
based instruction manuals and technical specifications and by obtaining input from subject 
matter experts.  The researchers presented this list to AF specialists at 12 AF field sites.  In 
addition, they collected specific, detailed information on the commands used on each system, 
including data on how specialists access the commands, the meaning of the commands, and the 
definitions of the commands.  In this way, they were able to identify commands that were 
different in terminology but performed the same function and commands that were similar in 
terminology but performed different functions.   

The researchers collected data on AF systems and equipment, identifying 25 different systems 
monitored and controlled by AF specialists.  Different AF systems had different means of 
interfacing with the computer (e.g., graphical user interface, menus, and command line 
interface).  They summarized data on the interaction types across AF systems to find that most 
AF systems used menus as the primary means of interacting with the system.     

Among the 25 systems monitored and controlled by AF, this research uncovered more than 1500 
options for accessing, interacting with, and controlling the equipment necessary to National 
Airspace System operations.  The researchers analyzed the options for frequency of occurrence 
and defined meanings for the most frequently used commands.   

They studied the meanings of the commands and identified commands with common meanings 
across systems as core commands.  They extracted a list of potential core commands and 
presented it to field personnel for validation and verification.   

Field personnel from various operational sites provided definitions for terms and validated 
information the researchers had collected on core commands.  A table within this document 
presents this set of core commands along with recommendations for their use.  

 



 

 1

1.  Introduction 

Airway Facilities (AF) is the part of the Federal Aviation Administration (FAA) that is 
responsible for maintenance, monitoring, and controlling facilities, systems, and equipment in 
the National Airspace System (NAS).   

AF consists of several components.  These components include a National Operations Control 
Center, three regional Operations Control Centers (OCCs), Service Operations Centers (SOCs), 
and Work Centers.  This report focuses on OCCs and SOCs.  OCCs provide coverage for all 
services and have significant monitoring and control functions with the exception of 
telecommunications.  SOCs cover all services and are responsible for complete monitoring and 
control for selected high impact Air Traffic (AT) facilities. 

Over the years, an increasing number of systems have been added to AF’s area of responsibility.  
Designers often develop or the FAA often procures these systems without considering existing 
systems or equipment.  Often, this results in different commands used to accomplish the same 
functions or the same or similar term used to accomplish different functions.   

1.1  System Interaction Methods 

There are many methods of interacting with a computer system, including direct manipulation, 
command line interaction, and menu interaction.  Often, computer systems rely on a combination 
of these methods. 

Systems relying on direct manipulation have a Graphical User Interface (GUI), which involves 
the use of visual symbols (sometimes known as icons) to represent the functions of a software 
program.  The user manipulates the symbols by using a pointing device such as a mouse.  
Various input devices including touch screens and keyboards also accomplish direct 
manipulation.  Direct manipulation of a GUI is beneficial to casual system users as a means of 
enhancing a user’s understanding of control actions or when offered as a simple alternative to 
learning a command language when computer response time is fast.  In an earlier study, 
Ahlstrom and Muldoon (2002) examined visual symbols used for interaction with AF computer 
systems. 

Systems that rely on command line interaction require the user to enter precise text sequences in 
the form of commands in order to interact with the system.  Command line interactions are 
sequences of instructions input by the user that result in system actions.  These instructions are 
usually a series of complete or abbreviated words or phrases that the user must recall and present 
in the particular order required by the system syntax.  Command line interactions sometimes 
require multiple interactions (between the user and the computer) using text strings that the user 
needs to recall exactly for successful system performance.  Command line text may be as simple 
as a two- or four-letter string entered via a keyboard.  However, some interactions can involve 
lengthy sequences of text that require exact user responses to system prompts or the use of a 
particular syntax before the system can accept a command.  In any case, recall from memory is a 
critical component of the interaction.  Many people are familiar with command line interaction in 
the form of the DOS and UNIX programs.  Command line interaction can be beneficial for tasks 
involving a wide range of control entries, where users may be highly trained and will use the 
system frequently and where control entries may be mixed with data entries in an arbitrary 
sequence.   
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Some software applications rely on menus to interact with the system.  Menus have the 
advantage of being usable with little or no training on the part of the user (if the meanings of the 
options are clear).  The disadvantages of menus are that they can occupy a considerable amount 
of display space and can slow down an experienced user if shortcut keys are not provided.  
Ahlstrom and Muldoon (2003b) examined menus and mnemonics for AF systems in a previous 
study. 

Specialists often use function keys (F keys) and shortcut keys for tasks requiring only a limited 
number of control entries.  They also use them in conjunction with other dialogue types as a 
ready means of accomplishing critical entries that must be made quickly and without syntax 
error.  In other words, specialists can use F keys to complete involved interactions while 
minimizing the number of key presses or mouse clicks.  This enables them to quickly and 
efficiently accomplish frequently used commands.  The disadvantage of F keys is that the user 
must remember with which command the F key is associated.  Templates placed on the keyboard 
can help the users remember which key is for which function.  Similarly, the user must 
remember which key combination activates particular commands for shortcut keys.  Ahlstrom 
and Muldoon (2003a) examined F keys and shortcut keys in a previous study. 

Each system in AF has a set of commands that it uses to interact with the system.  Specialists 
enable some of these commands through command interaction and through menus, F keys, form 
filling, or GUI.  Previous studies have covered several of these methods of interacting with 
systems (Ahlstrom & Muldoon, 2002, Ahlstrom & Muldoon, 2003a, 2003b).   

1.2  Purpose 

This study takes information from each of the prior studies to examine the commands 
themselves, regardless of the means of interacting with the system.  It identifies core high-level 
commands used across AF systems and how users currently enable these commands.  It 
determines whether the commands are consistent in meaning and use across systems and 
identifies commands that designers could standardize across systems.   

This study not only evaluates the core commands, but also evaluates the means of interacting 
with the AF systems and applications.  Although the term core commands could imply the most 
important commands, for the purpose of this report, core commands refer to commands that are 
common across systems. 

2.  Method 

A research team from the William J. Hughes Technical Center Human Factors Group (ACB-220) 
previously collected data on F keys, GUIs, and menus.  Ahlstrom and Muldoon (2003a, 2003b) 
presented the results of the data collection in two technical notes.  This study takes a broader 
look across systems and interaction modality based on the data collected in the previous efforts.   

2.1  Site Visits 

Researchers targeted 12 sites for their location and diversity and so they could visit more than 
one type of facility per location (i.e., an Air Route Traffic Control Center (ARTCC) and an OCC 
in one city).  These sites are Chicago Terminal Radar Approach Control Facility (TRACON) and 
ARTCC; Seattle TRACON and ARTCC; Atlanta TRACON, ARTCC, and OCC; Dallas Fort 
Worth TRACON and ARTCC; and San Diego TRACON, ARTCC, and OCC.   
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2.2  Data Collection 

To minimize the time needed for data collection at each site visit, researchers used computer-
based instruction manuals and available software documentation to gather information on 
command conventions and command interaction for each system prior to conducting the site 
visits.  They verified and expanded upon this information at the sites.  The time and staffing 
constraints inherent to any busy operation and approval by union and management placed 
contingencies on their visits to these sites.  Both the AF specialists and the research team ensured 
that data collection would not impact AF operations.   

2.3  Procedure 

A research team analyzed computer-based instruction manuals and system specifications and, 
with the help of Subject Matter Experts (SMEs), extracted a list of potential “Core” functions.  If 
they found a function used by more than six systems during this preliminary investigation, they 
placed it in the list (Table 1). 

Table 1.  Potential Core Functions 

Acknowledge Next 

Alarm Open 

Change Previous 

Clear Print 

Close Save 

Control Search 

Delete Send 

Edit Start 

File Status 

Find Stop 

Help Time/Clock 

Load Validate 

LogOff/On  

 

At each site, a member of the research team met the Points of Contact (POCs) and thanked them 
for their time.  The researcher then explained the purpose of the study.  The POCs and others 
available and interested in participating in this study received a brief, written description 
explaining its purpose and containing project contact information.  He made available other 
pertinent coordination information upon request, including the names of management and union 
personnel with whom they coordinated prior to the study.  He distributed a written statement of 
confidentiality and asked study participants to sign it.  The researchers assured the participants 
that he would keep any responses to questions confidential and only a participant number would 
identify data.   
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The research team presented AF specialists with the list in Table 1.  A researcher then paired 
with an individual and went through a system in detail.  Which system the specialist felt most 
knowledgeable about and comfortable talking about determined the system discussed.  With the 
system in clear view, the researcher asked the specialist, item by item, if that listed option was 
available with that system, how one would enable that option, and what kind of meaning that 
option held for that system.  The researcher encouraged the specialist to comment on the list of 
core commands.  This provided the team with information on options that were different in 
wording but similar in functionality.  Additionally, this exercise provided some information on 
the frequency of use for different options.  At each site, researchers observed the systems in use 
and decided whether the primary method of interaction was through command line interaction, F 
keys or shortcut keys, or a GUI.   

In addition to the comments made on the list of potential core commands, researchers created a 
detailed list of options for each system.  Additionally, they captured information on the system 
associated with the option, the meaning associated with the option, and the method of interaction 
(e.g., icon, shortcut key, F key, menu).  They placed all of these options in a spreadsheet for 
analysis.   

3.  Results 

Researchers identified 25 different systems used in AF operational environments.  The majority 
of the systems display the status of NAS components for monitor and control purposes.  These 
systems often present information either in the form of visual symbols indicating the NAS 
component being monitored with an accompanying color or state change indicating status, or 
through lists in which status is generally indicated by color change.  One exception, a system that 
provides a means of event ticketing or event logging, uses form filling as the primary means of 
interaction.   

3.1  Systems and Displays in the AF Environments 

The researchers collected detailed information on how the AF specialists use each system and the 
primary and secondary means of interacting with the system.  Table 2 summarizes these data. 

Table 2.  Individual System Information 

System Name Information for AF Primary Access Secondary Access 

Automated Radar Terminal 
System (ARTS) 

View status of AT radar positions, interact with files, 
create or change plots, reconfigure AT positions, 
monitor and control AT positions for radar, test AT 
radars 

Pull-down menus with 
mouse 

Command line (rarely 
used or taught) 

Codex View connectivity and network equipment status, 
monitor and control network connectivity, reconfigure 
communication networks, test network connectivity, 
interact with various communication layouts 

Unique three-button 
mouse, icons 
(activating pop up 
menus) 

Dedicated F keys 
from unique keyboard

Center TRACON 
Automation System 
(CTAS) 

Not yet observed with AF interactions, expected use will 
be Acknowledge alarms, silence alarms, view object 
information, M&C network connectivity, see which 
system is in control, determine error rates and 
percentages, export data 

Pull-down menus with 
mouse 

Keyboard 
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System Name Information for AF Primary Access Secondary Access 

Data Acquisition 
Subsystem Real-time Status 
Display (DAS/RSD) 

View events/status lists by subsystem or date/time, view 
connectivity and status of EDARC, provides scrollable 
lists of event data and allows acknowledgement of 
events, shows schematic of connectivity with EDARC 
screen 

Point and Click with 
Mouse 

Keyboard (rarely 
used) 

Direct Access Radar 
Channel (DARC) 

Interact with alarm/event files, backup system for Host.; 
will provide direct M&C for all n route radars; limited 
options and presentation compared to Host 

Pull-down menus with 
mouse 

Command line  

Display System 
Replacement (DSR) 

M&C Host, M&C EDARC, M& C Certification shows 
status, allows maintenance and control, allows 
certification 

Point and click with 
Trackball, three button 
options and dedicated 
F keys from unique 
keyboard 

 

Digital Voice Recording 
System (DVRS) 

View status logs, history logs, event logs; generates 
system alarms, monitors recordings, interfaces with 
VSCS 

Pull-down menus with 
mouse 

 

Enhanced Traffic 
Management System 
(ETMS) 

Shows maps of different regions with traffic overlays; 
AF performs monitor and control, navigate directory 
structure, print files, obtain help, and control data output 

Pull-down menus with 
mouse 

Command line  

Event Manager (EM) Used to input, manage, track and coordinate events  Form-filling using 
mouse clicks and 
standard keyboard 
entries  

 

Host Direct M&C for en route radar positions; reconfigure AT 
positions, view event/ status lists, switchover to backup 
systems, run dynamic simulations for equipment checks 

Command line   

Host Interface Device 
(HID) National Airspace 
System (NAS) Local Area 
Network (LAN) 

Monitor and manage hardware and software applications Pull-down menus with 
mouse 

 

Host and Oceanic Computer 
System Replacement 
(HOCSR) 

Monitor and control including acquiring  Pull-down menus with 
mouse 

 

Interim Monitor and 
Control Software (IMCS) 

Monitor and control subsystems; view subsystem status; 
provides phone line connectivity, assume relinquish 
control of subsystems, create event logs 

Command lines and 
mouse click on 
pictograph icons used 
in conjunction  

F keys and F keys 
with Shift as a 
modifier 

Low Level Windshear Alert 
System (LLWAS) 

View alarm/status lists; control of limited system 
statuses, acknowledge alarms 

Viewed but not 
interacted with 

 

Low Density Radio 
Communications Link 
(LDRCL) 

Monitor status, acknowledge alarms, phone line connect 
with field technicians 

Mouse point and click  
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System Name Information for AF Primary Access Secondary Access 

Maintenance Automation 
Software System (MASS) 

Monitor and control subsystems; assume/relinquish 
control of subsystems; create event logs; view history, 
event, and system files; view system messages; drill 
down to a “Quick View” of a single event/subsystem; 
view subsystem status 

Pull-down menus with 
mouse in conjunction 
with scrollable lists 
with mouse 

Provides mnemonics, 
but never saw them 
used 

Mode-S View alarm/event lists, initialize and switch channels, 
request or release control of radar system for 
maintenance and testing 

Pull-down menus and 
clickable text icons 
with mouse 

 

Random Access Plan 
Position Indicator (RAPPI) 

View facility radar input equipment status, select/switch 
Radar Data Distribution Unit (RDDU), enable/disable 
alarms 

Equal use of mouse 
and menus and 
keyboard dedicated 
number keys 

 

Radio Communications 
Link (RCL) 

Switch operating channels, view commands 
status/progress, access information from other comms 
sites, search for alarms, view most recently used 
commands 

Command line with 8 
mouse-clickable 
options 

F keys for the same 8 
options 

Rapid Deployment Voice 
Switch (RDVS) 

This DOS based system incorporates pull-down menus 
to view status of Air-to-Ground (A/G) and Ground-to-
Ground (G/G) communications at TRACON.  AT 
positions can be monitored individually or en masse.  
View alarm lists, switch to backup systems, reconfigure 
AT positions 

Pull-down menus with 
mouse 

 

Standard Terminal 
Automation Replacement 
System (STARS) 

View status of AT radar positions, interact with files, 
create or change plots, reconfigure AT positions, 
monitor and control AT positions for radar, test AT 
radars 

Point and click on 
Text icons with mouse 

 

Very High Frequency 
Omnidirectional 
Range/Tactical Air Co-
located (VORTAC) 

Acknowledge abnormal conditions, change 
channels/monitor control, control various system 
functions, change parameters, view history/event logs, 
monitor system data, troubleshoot and identify parameter 
deviations 

Command line   

Voice Switching and 
Control System 
Maintenance Position 
Equipment Subsystem 
(VSCS [MPES]) 

Control alarm level, change from primary/secondary 
(manually), troubleshoot/diagnose system events, view 
fault/status lists, create/view reports, customizable by 
facility, reconfigure AT positions  

Mouse clicks from 
pull-down menu bar 

 

VSCS Training and Backup 
System (VTABS) 

Acknowledge alarms, control alarm volume, view 
connectivity status, view event details, change to 
primary (VSCS) manually, view/update AT position 
maps, reconfigure AT positions 

Pull-down menus with 
mouse 

 

Weather and Radar 
Processor (WARP) 

View weather map data, view alarm lists and logs, 
acknowledge alarms, view system messages, cascade 
weather images  

 Pull-down menus 
with mouse 
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They analyzed the overall list of options by the method of access.  These data gave information 
on the most frequently occurring methods of access and the number of systems that use each 
method of access (see Table 3).  The number of systems in the third column of Table 3 adds up 
to more than 25 because there are often redundant means of accessing options.  For example, an 
icon, a menu bar, or a shortcut key could access the print command in the same system.   

The primary means of interacting with most AF systems are menus with redundant keyboard 
entries, and the least common methods of interaction are command-line interface and form filling 
(not included in the table because only one system used this method and the options for that 
system were not examined in detail).  The AF systems often used graphics either as a means of 
showing status or as part of a graphical menu rather than for the purposes of direct manipulation.  
Some AF systems have graphics, menus, and keyboard entries present as a means of interacting 
with the system.   

Table 3.  Method of Option Access Across Systems 

Option Type Options Accessed Through 
This Method 

Percentage of Options Systems Employing This Access Method 

Menu Bar  834 55.3 15 

Icon  215 14.2 17 

F key  157 10.4 18 

Shortcut Key 67 4.5 9 
 

3.1.1  Frequency of Option Occurrence 

Among the 25 systems monitored and controlled by AF, there were over 1500 different options 
identified for accessing, interacting with, and controlling the equipment necessary to NAS 
operations.  The researchers analyzed the frequency of occurrence of these options.  In other 
words, how many times did this term occur regardless of the method used to access the term?  
Table 4 shows the most frequently occurring terms, and many from Table 1 appear in Table 4.  

There are several things that this analysis did not provide.  First, it did not differentiate whether 
the option was a command or a means of navigation or categorization.  For example, a means of 
navigation would be menu bar items that open additional menus.  Many menu bars contain the 
Edit option, and when the user selects this, it generally opens a pull-down menu of other options.  
Thus, the Edit option serves more as a navigational tool or means of categorizing commands 
rather than a command in and of itself.  However, operators could also use Edit as a command 
for some systems if using that option to actually edit an item.  Secondly, they identified how 
often these items occurred in the different systems, but that did not provide them with 
information on how often specialists used these options.  The potential core functions were the 
closest estimate of frequency of use for commands that they were able to get from the specialists.  
Third, the frequency counts did not differentiate items that occurred in isolation from those that 
occurred as part of a phrase.  
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Table 4.  Most Frequently Encountered Options Across Systems 

Command/Attribute Frequency Number of systems using 
Alarm/Alert 42 17 
Status 35 20 
Print 33 20 
Show 32 3 
Delete 31 11 
Help 31 17 
Display 30 12 
Clear 29 17 
Save 27 15 
Acknowledge 24 13 
Close 23 14 
Configure/Reconfigure 22 10 
Find/Search 22 18 
Change 20 18 
Open 20 13 
Edit 19 16 
Next 19 13 
View 18 10 
Select 18 6 
Report 17 11 
System 17 7 
Exit 16 12 
Control 16 10 
Login/Logout 16 14 
Previous 14 11 
Get/GoTo 14 5 
Map 14 6 
About 12 10 
Start/Restart 11 11 
Event 11 8 

 

By taking the frequently occurring options and presenting them to AF specialists at operational 
field sites, the researchers were able to verify how they used these options and clarify the 
meaning of over 80% of the options.  This allowed them to identify some different terms that 
accomplished a similar function.  They also were able to identify commonalities in how 
operators used terms.   

4.  Conclusions 

The researchers found several instances across AF systems where specialists use different terms 
to accomplish the same function.  Some examples of these are Exit and Quit; Logout and Log 
Off and Sign Off; Show, Display and View; Print and Send to Printer; Clear, Erase, and Delete; 
Change, Go to, Switchover, Primary/standby, Channel change, Switch, and Change operational 
system; Refresh, Redraw, and Replot; and Restore and Default.  There were also instances of the 
same command accomplishing slightly different functions, such as View and Edit.  They also 
found inconsistencies in where commands were located and how they were activated in the 
system (e.g., function key, menu, typed in command).  Tables 5 and 6 expand upon these 
instances. 

In this document, the researchers identified frequently used methods of interacting with 
computer systems.  They analyzed the frequency of occurrence for commands across systems 
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and identified definitions and recommendations for use based on the information provided by 
SMEs, human factors guidelines, and computer-based instruction manuals.  These frequently 
occurring terms matched closely with the frequently used commands list provided in Table 1.  

In this section, the researchers expand on the most frequently occurring terms, provide 
information about their use in AF systems, and recommend their use and access (Table 5).  They 
recommend that when using these core terms, designers consult the definitions, placement, and 
terms for common AF function as described in the following tables.  By standardizing the terms 
and how the terms are accessed (including where they are located) across systems, consistency 
among systems can be achieved, making it easier for specialists to use the systems.  

Table 5.  Common AF Commands 

Command Description Recommendations 

Alarm/Alert Alarm is sometimes combined with the term Alert and 
used as an item in a menu bar.  Alarm appears in several 
different forms across AF systems.  The primary use is in 
conjunction with the word “Show” to open a list of alarms 
that often can be individually acknowledged, generally 
through the use of a pointing device.  The location of this 
function (show a list of alarms/alerts) is inconsistent 
across AF systems.  Sometimes it is located under 
Alarms/Alerts in the menu bar; in other cases it is under 
Fault, Alerts, Tools, View, Status, Utilities, and Screens.  

The function “Alarm list” should use consistent 
terminology and be consistent in location.  They 
recommend placing this item under the View 
menu where possible and using a single term to 
access the alarm status lists.  

Status Status is a very common command.  It is used to access 
either overall single system status (health/heartbeat) or, in 
cases where systems monitor subsystems, the status of a 
subsystem.  This option is accessed generally through the 
menu or through an F key.  When selected, this option 
must display the status of relevant items.  Status can also 
be accessed for some systems through an icon or manually 
entered core command, allowing the specialists to access 
status information for specific sites or pieces of 
equipment.   

Subsystem status displays are occasionally the default 
screen.  For example, MASS presents the status of 
subsystems as default.   

The term “Status” should be used to provide 
status for the system or for subsystems.  It 
should appear in conjunction with the name of 
the item whose status will be displayed. 

Status Bar This option serves to display the status bar. When selected, this option must display the 
status bar with systems that employ one. 

Print This option is used to send information to the printer.  
Print is sometimes assigned to a visual symbol.  Print is 
sometimes accessed with a non-dedicated function key 

When selected, this option must open a dialog 
box to request information necessary to print 
and then send a selected item to the printer.  In a 
menu, this option must be followed by ellipses 
indicating that further information will be 
requested of the user.  This option should be 
located in the File menu with menu driven 
systems, and should be indicated by the 
mnemonic P and assigned the shortcut Ctrl + P.  
When assigned to a visual symbol, Print should 
be signified by an icon that resembles a printer 
with a piece of paper sticking up on it.   
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Command Description Recommendations 

Show/Display “Show” is almost exclusively seen together with a noun or 
noun phrase.  “Show” appears to be used synonymously 
with “Display” and occasionally “View.” 

“Display” can be accessed through menu or F keys, 
primarily F key, and is seen primarily in a single system.   

Choosing this option must make visible the 
indicated noun.  The researcher recommend 
using the show option instead of display, as 
display could be used to indicate a physical 
display and thus is not as informative as show. 

Delete “Delete” (found in 11 systems) is used more than 20 times 
across systems.  The delete command can be accessed 
either through a dedicated key on the keyboard or a menu 
option.  It performs a function redundant with the clear 
function.   

The delete command serves to remove selected data from 
the active area.   

 

The delete function is frequently redundant with 
the Clear option; it is recommended that either 
clear or delete be used, not both. 

The delete option should have the mnemonic D 
if used as a menu option and should appear in 
the “Edit” menu. 

One system uses the term “Erase” instead of 
Delete.  Erase should be replaced with delete 
because it serves the same functionality. 

They recommend using the standard methods of 
highlighting and the delete key together with 
modifier keys, instead of the following submenu 
options: Delete Entire Line, Delete Last Word, 
Delete to End of Line, Delete Previous 
Character, and Delete Current Character. 

If placed in a menu, it should generally be 
located in the Edit menu.  

They recommend that a dialog box appear 
requesting that the user confirm the action and 
informing the user that the action cannot be 
undone for delete actions that cannot be undone.   

Clear “Clear” is used in two different ways across AF systems.  
In one instance the option clear is used alone and together 
with another word or words specifying exactly what 
should be removed from the current view (e.g., clear all 
flashing).  “Clear” is also used to remove a selected 
portion of data without copying it to the clipboard or 
compressing the remaining data.   

Means of accessing this command vary greatly across AF 
systems.  The most common methods of accessing this 
command are through menus and the F keys of either F2 
or F3. 

If “Clear” is used in the sense of removing a 
selected portion of data without copying it to 
the clipboard, they recommend that the 
command Delete be used for this function 
instead.  

 

 

Help “Help” occurs in the menu bar in menu driven systems 
and as a Non-Dedicated function key (F key) with other 
systems.  “Help” is sometimes accessed through an icon in 
GUI systems. 

Selecting “Help” from the menu bar should 
open the Help menu.  The Help menu should be 
the last menu bar item on the right and should 
contain options that provide help to the user.  
The mnemonic for “Help” should be H in menu 
driven systems.   

The F key F1 should be used to access help.  
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Command Description Recommendations 

Save This command is seen frequently across systems as a 
means of saving information to the computer hard drive.  
This action is often accessed through menus, shortcut 
keys, or an icon.   

This command should save a file to a storage 
device under the file’s current name.  If the file 
does not have a name, this command should 
open a dialog box, prompting the user to enter a 
file name.  This command should be located 
under the File menu in menu driven systems, 
with the mnemonic S.  It should have the 
shortcut Ctrl + S.  When accessed through an 
icon, the symbol on the icon should resemble a 
diskette. 

Acknowledge The function of the acknowledge option is usually to 
acknowledge alarms or event occurrences.  The use of this 
term varies.  Sometimes this term is used to acknowledge 
all of the unacknowledged alarms, sometimes to 
acknowledge audible alarms, and sometimes to 
acknowledge visual alarms.   

The location of this option varies widely.  In different 
systems it is under the View menu, a Utilities menu, a 
Software menu, and a Fault menu.  In some systems, this 
option is given a dedicated F key; in other systems it is 
assigned to an F key; in another system a two-letter 
keyboard command is used.  For some systems, selecting 
Clear All Flashing or Clear Selected Flashing 
accomplishes this same function from a menu.  Other 
systems acknowledge alarms by clicking on an item with 
the mouse.   

A major use of this function is to acknowledge 
auditory alarms.  Specialists reported this option 
as a frequently used option.  Thus, there should 
be a consistent means of acknowledging alarms 
across systems.  In general, the authors 
recommend that, when this command is used, it 
should cause the auditory portion of the alarm 
to be temporarily silenced (with the visual 
portion of the alarm still indicating the problem 
until the condition is resolved).  They 
recommend that an F key be assigned the 
function of acknowledging auditory alarms.  
The key assigned to this function should be 
consistent across systems.  They recommend F5 
for this function.   

Acknowledge Alarms should not be located in 
the View menu, as the View menu should be 
reserved for actions that do not change the data.  

Acknowledgment of visual alarms and the 
ability to acknowledge all alarms should be 
located consistently from one system to another.  
The use of the term acknowledge is preferable 
to the term clear for this function.  
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Command Description Recommendations 

Close The close option is used to close windows of an 
application.  It differs from the Exit command in that 
“Exit” closes the entire application while “Close” only 
closes the subwindows of the application but leaves the 
application open.  

It is found in File, Map, and Windows submenus in AF 
systems.  In the Windows submenu, it is used together 
with the modifier “All” (Close All).   

This option is usually only available in dialog boxes that 
provide status information or in dialog boxes that perform 
irreversible actions. 

This command should only be used for 
applications that have multiple independent 
windows, not with applications that have single 
windows.  This action must only close the 
current primary window and its associated sub 
windows and remove them from the workspace 
without ending the application.  For most 
windowing systems, close can also be 
accomplished by clicking on X icon in the top 
right hand side of the window itself.  It should 
have the mnemonic C when used in menus.   

If the Close all option causes all of the windows 
to be closed and the closing of the associated 
application, the command Exit is preferable to 
Close All.   

Before closing the window, the application must 
prompt the user to save any unsaved changes 
that might result in a loss of data.  

The Close option should be located in the File 
(or equivalent) menu for menu driven systems.  

Use Close to close subwindows of the 
application but not to close the entire 
application.  

When used in dialog boxes, this command 
should cause the dialog box to close without 
performing any of the specified actions.       

Configure/ 
Reconfigure 

“Configure,” “Reconfigure,” and “Configuration” are 
commands that are fairly unique yet very important to a 
monitor and control environment like AF.   

“Configure” and “Reconfigure” allow the user to modify 
settings, while configuration allows the user to view the 
current settings.  The way these options are accessed in 
current AF applications varies widely, from icons to 
menus, to F keys.  The location of the option in a menu 
varies widely from one system to another.  It is located in 
the Options menu, Monitor menu, Configuration menu, 
and Status/Recon menu.  

Due to the importance of this function for AF 
systems, they recommend placing the 
commands configure and configuration in a 
standard location across systems where 
possible.  Where “Reconfigure” is used 
synonymously with “Configure,” they 
recommend using “Configure.”  

One possibility for the command configuration 
is to place it in the View menu for menu driven 
systems as it allows the current settings to be 
viewed but does not perform any 
transformations on the data.   

Find/Search The Find/Search command locates an item that matches a 
character string entered by the user.  The need to search 
for data is common in applications that display system or 
subsystem status.  It is important enough to rate dedicated 
symbols with Codex, EM, HNL, and HOCSR. 

A search option should be prominent among the 
various display access methods.  It is frequently 
found in the “Edit” pull-down menu of menu 
driven systems.  For menu driven systems, the 
mnemonic should be F, indicated by an 
underline, and the shortcut Ctrl + F should be 
assigned to this function.   

Change Channel change is a core function for AF systems 
although it is accomplished through many different terms.  
This function is the switching from one system to another 
system (usually a backup).  Some of the commands that 
result in a channel change are “Go To,” “Switchover,” 
“Primary/standby,” “Channel Change,” “Switch,” and 
“Change operational system”   

They recommend that only one term be used to 
identify this change functionality where 
practical across systems. 
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Command Description Recommendations 

Open The Open option opens an existing file (or map, 
depending on the application).   

This option must first open a dialog box and 
prompt the user for the name of the file.  If the 
completion of this operation will wipe out 
current changes to the file, a dialog box must 
appear, providing the user with the option of 
saving the changes before performing the 
action.  This option should have the mnemonic 
O for menu driven systems.  When in a menu, 
this option should be located in the first menu 
on the left of the menu bar (generally the File 
menu) where possible. 

Edit “Edit” is an item on a menu bar, common across many AF 
applications.  In general, it is not a command per se, but 
rather a navigational or organizational item.  This 
command is usually located on the menu bar immediately 
to the right of the File option.  Selecting this item causes a 
submenu of options to become available.   

In some cases, “Edit” is used as a command, often with 
another word, specifying what will be edited.  Those cases 
are considered separately and are not frequent enough for 
this list. 

The Edit menu should be located consistently 
across systems to the right of the File menu. 

The Edit menu should contain the options 
Undo, Cut, Copy, Paste, Clear or Delete, Select 
all, Find, and Replace where appropriate.  

Next This command should be used to display the next item in a 
set of items or the next page or screen of information. 

This command should be used to display the 
next item in a set of items or the next page or 
screen of information. 

View “View” is usually used as a navigational item on the menu 
bar rather than a command.  “View” appears on the menu 
bar for several AF systems.  It is generally the third item 
on the menu bar when read from left to right.   

Sometimes, however, “View” is used as a command to 
show some item.  

Options placed in the view menu should allow 
the user to customize the appearance of the data 
in the window without altering the contents.  
The mnemonic for this menu option should be 
V when used in menus.   

They recommend not using “View” as a 
command, but using “Show” instead.  

Select This option appears followed by a noun or noun phrase 
specifying a category to be selected.   

Selecting this option should open a dialog box 
allowing the user to select specific instances of 
the category. 

Report “Report” as a menu bar option for AF systems opens a set 
of options that allows the user to choose and perform 
actions on reports.  Reports are also accessed with 
keyboards, icons, and typed in commands across the 
systems.  It also appears under the Tools, Options, and 
Utilities submenus on other systems.  This command 
appears both alone and with modifiers such as “Report 
Manager” and “Report Configuration.”  The function of 
this command is to generate, open, and allow the 
manipulation of a document with summary information on 
it. 

Consistent terminology should be used across 
systems, and it should be located in a consistent 
location across systems.   

System “System” generally appears as an item in the menu bar, 
specifying the system menu with systems having menu 
driven interfaces.   

When “System” is an option on a menu bar, it 
should appear as the first item to the left, prior 
to the File menu.  The system menu should 
allow the user the additional options to log on or 
log off, or to restart the system as appropriate.   
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Command Description Recommendations 

Exit The Exit option should close the current application and 
all primary and secondary windows associated with it and 
end the processing.  It is different than the Close option 
because Close leaves the application open. 

The option should prompt the user to save any 
unsaved data.  The mnemonic for this option 
should be X.  “Exit” should be located in the 
File menu of menu driven systems.  If the 
application does not have a File menu, “Exit” 
should be put at the end of the first pull-down 
menu. 

Some AF systems performed this same function 
using the word “Quit.”  As most AF systems 
use “Exit,” it is preferable to use “Exit” rather 
than “Quit” for this function.     

Control This command appears in different forms across different 
systems.  The primary function of this command is to 
allow the specialists to assume or relinquish control of a 
system.  In some systems this is accomplished through the 
use of F keys, clicking on an icon representing the item to 
be controlled, through a submenu, or through the use of 
shortcut keys.  “Control” is also used as a menu bar item 
and in one system is used to show control status.  It also 
appears together with “Configuration” (control 
configuration) in a submenu on one system. 

The means of assuming and relinquishing 
control of a system should be standardized 
across systems.   

Login/Out; 
Log on/Log 
off 

The Login command should open a dialog box requesting 
information to authenticate the user prior to allowing 
access to the system.  This information should consist of at 
least a user name and a password.  This menu option 
should be located under the system menu where possible.   

Some AF systems call this same function log on or sign 
on.  Sometimes “Login” is one word, and sometimes it is 
two words.  

“Log off” should end processing by the system, close all 
of the windows on the workspaces, and stop all 
processing.  It should request confirmation if unsaved 
changes have been made and allow the user to save the 
changes.   

A dialog box should prompt the user for the 
information. 

This function should be named the same across 
systems.   

After the user is logged in, the Log on option 
should change automatically to the option Log 
off. 

If used as a menu option, it should be located 
under the system menu where possible. 

Previous This item is associated with the Next option.  It is used to 
display the previous item in a set of items.  

This command should be used to display the 
previous item in a set of items. 

Map “Map” is generally used as a replacement for the word 
File in the menu bar for systems that do not manipulate 
text.  In general, the same rules that apply to the File menu 
apply to the Map menu in menu driven systems.   

It should generally be the first item on the left 
of the menu bar.  It should contain the same 
options as the File menu (New, Open, Print 
setup, Print, Close, Exit) as appropriate. 

Event Selecting the option Events (found in 8 systems) causes a 
list to appear displaying the current events.  This option is 
available for many systems but is inconsistent in its 
location.   

“Fault” is another menu option.  Fault, events, status, and 
alarms are all commands that are used to open a list 
displaying the current status of monitored items.  

It is recommended that the location of this item 
be standardized across systems. 

The authors recommend putting a command 
that allows the user to view a list showing the 
current status of monitored items in the View 
menu when menus are used.    
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Command Description Recommendations 

Get “Get” is usually seen in conjunction with a modifier 
specifying what item to get.  It returns a specific piece of 
information to the user.  

When “Get” is used redundantly with the Find 
function, they recommend using the Find 
command instead of the Get command. 

Go To “Go To” is often accessed through a shortcut key or F key 
command.  It takes the user to a specified location in a list 
of information or is used to switch channels on some 
systems. 

They recommend not using the Go To 
command to change channels for a system.  It 
can be placed in the Edit menu. 

About This option is generally found in menu driven systems and 
is followed by the name of an application or system.  

This option should provide information about 
the application or system.  It should be located 
under the Help menu.  It should have the 
mnemonic A. 

 

Additional commands that appeared at a frequency too low to make the most frequent list, but 
occurred often enough to warrant additional explanation appear in Table 6.  

Table 6.  Table of Additional Commands 

Command Description Recommendations 

Refresh/Redraw/ 

Replot 

This option should redraw/update the contents of a 
window.  In some systems that have “Map” instead 
of “File” in the pull-down menu bar, “Refresh” is 
generally placed in the Map menu.  

For systems that have File in the main menu bar, this 
item should be placed in the View menu where 
possible.  

Update “Update” should check the status of a process and 
display the updated information.  This option is 
often placed in the View menu.  In some systems, 
“Refresh” is used to accomplish the Update 
function as well as redrawing the contents of the 
window.  It is often assigned to the function key F9.  
Sometimes this function is accomplished through an 
icon on a graphic menu. 

AF systems should use “Update” to display updated 
information. 

Restore/Default “Restore” is frequently used when retrieving lost or 
damaged files.  In AF, “Restore” usually returns a 
system to a default state or setting.  In other 
systems, default settings are restored by the 
command default.  “Restore,” “Default,” and 
“Reset” are used synonymously in AF systems as a 
way of restoring default settings. 

Only one term should be used to restore default 
settings.  They recommend using the command 
Restore instead of Default as it is a verb 
commanding the system to restore settings.  (The 
term Default can also be used as a verb, to mean fail 
to do as required.)  This command should be used 
for restoring system, rather than screen, settings.  

Reset The command “Reset” cancels any changes made to 
the control settings that have not been applied and 
restores the settings to the values they had when 
first opened.   

“Reset” should only be used to restore screen 
specific (not system) settings to the values held by 
that screen when first opened.  

Options “Options” is often available on the menu bar of AF 
menu driven applications.  The contents of the 
Option menu will be application specific.   

If “Options” is used on the menu bar, it should 
contain items that permit customization of the 
application.  It should have a mnemonic of O. 
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Command Description Recommendations 

Paste Paste is currently used as an option with only three 
systems.   

For systems that require the ability to copy and paste 
items, this option should be found in Edit pull-down 
menus.  It should have the mnemonic P and the 
shortcut Ctrl + V.  

Pause/Halt/ 
Freeze/Hold 

All of these terms are used to interrupt operations. 
These options temporarily halt the task or computer 
actions and rendering in progress.    

The term Pause should be used instead of the terms 
Halt, Freeze, or Hold.  The action Pause should be 
used in combination with the command Resume.  
“Resume” must cause an action that was paused to 
begin again. 

Stop This term is used with three systems.  “Stop” is also 
indicated often on a graphic menu by a red icon 
with either an x or the shape of a stop sign. “Stop” 
is slightly different than “Pause,” as pause will not 
wait until the next possible breaking point, possibly 
leaving actions incomplete.  

“Stop” should be used to end the task in progress at 
the next possible non-destructive breaking point.   

Send The “Send” command is used to send messages or 
commands to another system.  Occasionally this 
command is used in conjunction with printer (Send 
to printer).  

“Send to printer” should be abandoned for the 
simpler and more common Print command. 
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Acronyms 

AF Airway Facilities 
ARTCC Air Route Traffic Control Center  
AT Air Traffic 
FAA Federal Aviation Administration 
GUI Graphical User Interface 
NAS National Airspace System 
OCC Operations Control Center 
POC Point of Contact  
SME Subject Matter Expert 
SOC Service Operations Center 
TRACON Terminal Radar Approach Control  

 


